Small number of customers may not see all cloud-joined devices

Incident Report for RealVNC

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 09:31 UTC

Monitoring

A fix has been applied to the affected customers and we are continuing to monitor the results.
Posted Mar 26, 2025 - 16:14 UTC

Identified

The issue has been identified and a fix is being implemented
Posted Mar 26, 2025 - 09:22 UTC

Investigating

A small number of customers may experience missing devices in their cloud team. While we work on resolving this issue, please try signing out of RealVNC Viewer and signing in again.
Posted Mar 21, 2025 - 11:11 UTC
This incident affected: RealVNC Connect (Connectivity Service).